酷Q社区

  • 登录
  • 注册
酷Q社区»社区 分享交流区 编程技术

【求助贴】想实现一个撤回功能[复制链接]

作者: 376105174|查看: 333|回复: 17
跳转到指定楼层
4-17 12:09

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x

功能就是:
       机器人(群主/管理)检测到群里有人发出任何消息后,延时一段时间再撤回(5s,1min,2min可以自己设定或者群员前面加时间设定前缀)

可以理解为阅后即焚清除所有记录的功能

有人可以帮助一下么?
我才接触这个不知道怎么弄,求助啊。。
买一个 pro 在开发就好
守望半吊子 发表于 2018-4-17 12:44
买一个 pro 在开发就好

昂 pro版本的已经买了 但是原理还不太懂 不知道怎么开发
.版本 2
.支持库 spec

.子程序 _eventGroupMsg, 整数型, 公开, Type=2 群消息
.参数 subType, 整数型, , 子类型,目前固定为1
.参数 msgId, 整数型, , 消息ID
.参数 fromGroup, 长整数型, , 来源群号
.参数 fromQQ, 长整数型, , 来源QQ号
.参数 fromAnonymous, 文本型, , 来源匿名者
.参数 msg, 文本型, , 消息内容
.参数 font, 整数型, , 字体

.如果真 (msg ≠ “”)
    延迟 (1000)
    CQ.撤回消息 (msgId)
.如果真结束
返回 (#消息_忽略)  ' 关于返回值说明, 见“_eventFriendMsg”子程

复制粘贴即可
隐患代码,一多会堵塞事件,楼主千万别复制粘贴... 详情回复 发表于 4-17 15:19
hui135135 发表于 2018-4-17 14:56
.版本 2
.支持库 spec

隐患代码,一多会堵塞事件,楼主千万别复制粘贴...
我笑喷了 不多说 详情回复 发表于 4-17 23:39
.版本 2

延时 (1000 × 60)
CQ.撤回消息 (消息id)

源码给你,自己看着整。同为 新人提醒下你打开官方的模板,然后输入cq就会弹出来所有酷Q的子程序。

被感谢 1

又见隐患代码...楼主千万别学....E4A是面向安卓APP的,易语言才是面向Windows的....酷Q是Windows程序所以你觉得是哪个呢 详情回复 发表于 4-17 22:21
墨影2 发表于 2018-4-17 17:42
.版本 2

延时 (1000 × 60)

昂 再问下 这些通常都是用E4a编程么
E4a是嘛玩意?没听说过,我只听说过易语言,java等 详情回复 发表于 4-17 19:32
376105174 发表于 2018-4-17 18:29
昂 再问下 这些通常都是用E4a编程么

E4a是嘛玩意?没听说过,我只听说过易语言,java等
墨影2 发表于 2018-4-17 17:42
.版本 2

延时 (1000 × 60)

又见隐患代码...楼主千万别学....E4A是面向安卓APP的,易语言才是面向Windows的....酷Q是Windows程序所以你觉得是哪个呢
墨影2 发表于 2018-4-17 19:32
E4a是嘛玩意?没听说过,我只听说过易语言,java等

噗,,我说错了 我想说的是E语言哈哈哈  E4a是编安卓app的中文编译器
微插件 发表于 2018-4-17 22:21
又见隐患代码...楼主千万别学....E4A是面向安卓APP的,易语言才是面向Windows的....酷Q是Windows程序所以 ...

嗯 说错了 不是e4A
易语言才对
376105174 发表于 2018-4-17 22:56
嗯 说错了 不是e4A
易语言才对

为什么都有隐患呢  那应该怎么编写才行啊。。。懵
隐患:酷Q的消息事件是通过线程触发的,但酷Q限定了线程数,长时间不去延时而不去释放会造成事件堵塞........事件堵塞了插件就无法再响应事件了...也就是说你运行一段时间发现不仅这个撤回插件无效了...其它的插件也都 详情回复 发表于 4-17 23:01
376105174 发表于 2018-4-17 22:58
为什么都有隐患呢  那应该怎么编写才行啊。。。懵

隐患:酷Q的消息事件是通过线程触发的,但酷Q限定了线程数,长时间不去延时而不去释放会造成事件堵塞........事件堵塞了插件就无法再响应事件了...也就是说你运行一段时间发现不仅这个撤回插件无效了...其它的插件也都没用了...
至于怎么编写...你是个初学者..不对你是个门外汉.连是什么语言编写的都不知道.先看基础再说吧
微插件 发表于 2018-4-17 15:19
隐患代码,一多会堵塞事件,楼主千万别复制粘贴...

我笑喷了 不多说
对楼上的代码质量不予置评,但是我要给楼主几点建议
①酷Q本身采用多线程调用应用的方式进行运行,因此不要在应用程序内使用“延迟”命令,这会导致CPU计算量激增。
②如果确实需要有这样的效果,可以考虑使用“延时”命令,但是这会堵塞酷Q线程,如果消息量大的话,同时堵塞过多线程会导致酷Q无法正常运行
③建议楼主采用(单调)队列这样的数据结构进行处理。

被感谢 2

王思聪 发表于 2018-4-18 11:38
对楼上的代码质量不予置评,但是我要给楼主几点建议
①酷Q本身采用多线程调用应用的方式进行运行,因此不要 ...

谢谢帮助 原来延迟延时命令还不一样呢
王思聪 发表于 2018-4-18 11:38
对楼上的代码质量不予置评,但是我要给楼主几点建议
①酷Q本身采用多线程调用应用的方式进行运行,因此不要 ...

昂 再问下 就是应用的话 直接用E语言直接编写出来生成.cpk文件就可以添加酷Q里面使用了么
对写好的程序静态编译,再用酷Q主程序打包cpk 详情回复 发表于 4-20 20:29
376105174 发表于 2018-4-18 22:55
昂 再问下 就是应用的话 直接用E语言直接编写出来生成.cpk文件就可以添加酷Q里面使用了么 ...

对写好的程序静态编译,再用酷Q主程序打包cpk
您需要登录后才可以回帖 登录 | 注册

本版积分规则尽量使你的回复能够对他人有所帮助

状态|Archiver|酷Q社区

Powered by Discuz!Designed by hexapp© 2018 CoolQ. All Rights Reserved.

快速回复返回顶部返回列表