酷Q社区

  • 登录
  • 注册
酷Q社区»社区 分享交流区 编程技术

[分享]取长整数型随机数[复制链接]

作者: 黯夜孤星|查看: 96|回复: 3
跳转到指定楼层
5 天前

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x

易语言自带的 取随机数(,) 命令只能取整数型范围的随机数,并且两个数字最大间隔为32767,对于游戏插件来说实在无法满足需求,故在此分享取长整数型随机数,同时赚点CP。

  1. .版本 2

  2. .子程序 取长随机数, 长整数型
  3. .参数 最小值, 长整数型
  4. .参数 最大值, 长整数型
  5. .局部变量 长度, 长整数型
  6. .局部变量 随机数, 长整数型

  7. 长度 = 最大值 - 最小值  ' 随机数的区间长度
  8. 随机数 = 最小值
  9. .判断循环首 (长度 > 32767)  ' 取随机数最大长度为32767
  10.     长度 = 到长整数 (长度 ÷ 2)  ' 每次取区间长度的一半,重新赋值给区间长度
  11.     置随机数种子 ()
  12.     .如果真 (取随机数 (1, 100) > 50)
  13.         随机数 = 随机数 + 长度  ' 50%概率累加一半的区间长度,最后得出累加值
  14.     .如果真结束

  15. .判断循环尾 ()
  16. 置随机数种子 ()
  17. 长度 = 取随机数 (0, 长度)  ' 在区间长度中随机取一个值
  18. 随机数 = 随机数 + 长度  ' 最终得出 随机数 = 累加值 + 随机区间值
  19. 返回 (随机数)
复制代码
TIM截图20190414164332.png


取长随机数.e (3.14 KB, 下载次数: 0)
这个,有什么实际用途吗?

同时赚点CP

划重点
同时赚点CP
您需要登录后才可以回帖 登录 | 注册

本版积分规则尽量使你的回复能够对他人有所帮助

Powered by Discuz!Designed by hexapp© 2019 CoolQ

快速回复返回顶部返回列表