酷Q社区»社区 酷Q 应用发布 · 创意

[免费(开源)] [晓风]数学工具集[复制链接]

12下一页
作者: xzy910|查看: 440|回复: 22
跳转到指定楼层
5-16 19:59
[晓风]数学工具集1.0.0
appidme.cqp.morsor.mathsV9
类型工具 
许可禁止二次发布
介绍一款解决你各种头疼数学问题的插件!
本帖最后由 xzy910 于 2020-5-16 20:09 编辑

晓风系列插件又来啦!
数学工具集!
介绍
遇到某些数学题(如判断质数),抓耳挠腮想不出来?
晓风系列产品《数学工具集》,一个插件,全部搞定!
(目前作者只想到一个判断质数问题,更多功能欢迎评论反馈)
不废话,上图
主界面:
操作演示(以判断质数为例):
使用说明
判断质数:【命令前缀】+【质数命令】+【欲判断数字】
其他功能:敬请期待……
另外,希望大家不要虐待它!输个很大很大的数字,谁受得了……
下载插件
V1.0.0(最新)
- 最初版本

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
本帖最后由 xzy910 于 2020-5-16 20:05 编辑

忍痛撒出30CP,随机奖励给3位幸运者!每人10CP !
这款插件的未来就看大家的积极回帖了!希望大家踊跃反馈!
支持一下作者辛苦了 详情回复 发表于 5-16 20:47
提示: 作者被禁止或删除 内容自动屏蔽
判断质数2
希望以后可以解方程

被感谢 1

后续添加 详情回复 发表于 5-17 09:00
前排支持楼主
xzy910 发表于 2020-5-16 20:02
忍痛撒出30CP,随机奖励给3位幸运者!每人10CP !这款插件的未来就看大家的积极回帖了!希望大家踊跃反馈! ...

支持一下作者辛苦了
希望有更多数学工具
回复使用道具举报
1arn@5-16 20:56 +10 CP
看不到图 二元二次方程能解出来然后带步骤吗
提示: 作者被禁止或删除 内容自动屏蔽
  1. .版本 2

  2. .子程序 晓风_判断质数, 逻辑型, 公开, 传入一个数字,如是质数返回真,反之返回假。
  3. .参数 数字, 整数型
  4. .局部变量 除数, 整数型

  5. .如果真 (数字 = 1)
  6.     返回 (假)
  7. .如果真结束
  8. 除数 = 2
  9. .判断循环首 (除数 ≤ 求平方根 (数字))
  10.     .如果 (数字 % 除数 = 0)
  11.         返回 (假)
  12.     .否则
  13.         除数 = 除数 + 1
  14.     .如果结束

  15. .判断循环尾 ()
  16. 返回 (真)
复制代码

帮你修改了下判断质数的函数,实际上除数只要能到根号(N)就行了,再往后都是无用计算,可以大大的优化速度
另外判断能否整除可以用取模运算(%)

被感谢 1

感谢修改 详情回复 发表于 5-17 08:58
164980 发表于 2020-5-16 21:15
帮你修改了下判断质数的函数,实际上除数只要能到根号(N)就行了,再往后都是无用计算,可以大大的优化速度 ...

感谢修改
wszbzb 发表于 2020-5-16 20:45
希望以后可以解方程

后续添加
解方程有的网站有接口,你可以找找直接接上
能推荐一个吗? 详情回复 发表于 5-19 21:46
CP有吗?
小小桃妖怪 发表于 2020-5-18 15:33
解方程有的网站有接口,你可以找找直接接上

能推荐一个吗?
还行不错啊
太棒了!!!!
你这判断质数的算法也太暴力了吧,网上有很多优秀的算法,建议学一下
额。。支持一下
您需要登录后才可以回帖 登录 | 注册

本版积分规则尽量使你的回复能够对他人有所帮助

Powered by Discuz!Designed by hexapp© 2020 CoolQ

快速回复返回顶部返回列表