酷Q社区»社区 分享交流区 编程技术

群员@某人怎么取被@的帐号[复制链接]

作者: qinlongpk|查看: 180|回复: 5
跳转到指定楼层
5-22 05:07

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
正在写加款扣款,怎么取出被@的人的帐号
Q$HM`[]KH_XNOF3`YM~QE@D.png
本帖最后由 AlvinLiang 于 2020-5-22 09:32 编辑

str = 取文本之后 (msg, “加款”)
str = 文本_取出中间文本 (str, “[CQ:at,qq=”, “]”)
PS:取文本之后的子程序自己写或者百度~
  1. .版本 2

  2. .子程序 取被艾特人账号, 长整数型
  3. .参数 消息, 文本型
  4. .局部变量 左边位置, 整数型
  5. .局部变量 右边位置, 整数型

  6. 左边位置 = 寻找文本 (删全部空 (消息), “=”, , 假)
  7. 右边位置 = 寻找文本 (删全部空 (消息), “]”, , 假)
  8. 返回 (到长整数 (取文本中间 (消息, 左边位置 + 1, 右边位置 - 左边位置 - 1)))
复制代码
扣扣=到长整数(文本—取中间(msg,=,]))
精易模块
[CQ:at,qq=帐号]
用正则匹配出来
您需要登录后才可以回帖 登录 | 注册

本版积分规则尽量使你的回复能够对他人有所帮助

Powered by Discuz!Designed by hexapp© 2020 CoolQ

快速回复返回顶部返回列表